EasyApache 5 January 2017 Maintenance Release

  • in Blog Posts
  • by
  • January 6, 2017
  • Comments Off on EasyApache 5 January 2017 Maintenance Release

SUMMARY
cPanel, Inc. has released updated RPMs for EasyApache 4 on January 5, 2017, with Apache version 2.4.25. This release addresses vulnerabilities related to CVE-2016-0736, CVE-2016-2161, CVE-2016-5387, CVE-2016-8740, and CVE-2016-8743. We strongly encourage all Apache 2.4 users to upgrade to version 2.4.25.

AFFECTED VERSIONS
All versions of Apache 2.4 through version 2.4.23

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2016-0736 – MEDIUM
Apache 2.4.25
Fixed bug in mod_session_crypto related to CVE-2016-0736

CVE-2016-2161 – MEDIUM
Apache 2.4.25
Fixed bug in mod_auth_digest related to CVE-2016-2161

CVE-2016-5387 – HIGH
Apache 2.4.25
Fixed bug in Core related to CVE-2016-5387

CVE-2016-8740 – HIGH
Apache 2.4.25
Fixed bug in mod_http2 related to CVE-2016-8740

CVE-2016-8743 – MEDIUM
Apache 2.4.25
Fixed whitespace parsing defects related to CVE-2016-8743

SOLUTION
cPanel, Inc. has released updated RPMs for EasyApache 4 on January 5, 2017, with a updated versions of Apache 2.4.25. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM’s Run System Update interface.

REFERENCES
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-8740
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-5387
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-2161
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-0736
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-8743
http://www.apache.org/dist/httpd/CHANGES_2.4.25

For the PGP-signed message, please see ea4-2017-1-4-cve

SUMMARY
cPanel, Inc. has released EasyApache 3.34.10 with Apache version 2.4.25. This release addresses vulnerabilities related to CVE-2016-0736, CVE-2016-2161, CVE-2016-5387, CVE-2016-8740, and CVE-2016-8743. We strongly encourage all Apache 2.4 users to upgrade to version 2.4.25.

AFFECTED VERSIONS
All versions of Apache 2.4 through version 2.4.23

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2016-0736 – MEDIUM
Apache 2.4.25
Fixed bug in mod_session_crypto related to CVE-2016-0736

CVE-2016-2161 – MEDIUM
Apache 2.4.25
Fixed bug in mod_auth_digest related to CVE-2016-2161

CVE-2016-5387 – HIGH
Apache 2.4.25
Fixed bug in Core related to CVE-2016-5387

CVE-2016-8740 – HIGH
Apache 2.4.25
Fixed bug in mod_http2 related to CVE-2016-8740

CVE-2016-8743 – MEDIUM
Apache 2.4.25
Fixed whitespace parsing defects related to CVE-2016-8743

SOLUTION
cPanel, Inc. has released EasyApache 3.34.10 with an updated version of Apache 2.4.25. Unless you have disabled EasyApache updates, the EasyApache application updates to the latest version when launched. Run EasyApache to rebuild your profile with the latest version of PHP.

REFERENCES
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-8740
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-5387
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-2161
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-0736
https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-8743
http://www.apache.org/dist/httpd/CHANGES_2.4.25

For the PGP-signed message, please see ea-3-34-10-cve

Comments are closed.